The .NET Framework versions 3.5 and 4.5 are required external dependencies. The ThingWorx Manufacturing Apps installer will prompt you to install these.


For more information on the System requirements and External dependencies, see: ThingWorx Manufacturing Apps Setup and Configuration Guide.pdf


If you are a previous ThingWorx user, and are not using the full ThingWorx Manufacturing Apps installer, you will need to add these framework versions to the Windows operating system. An installer is available from the PTC App store for this purpose, or this can be done manually by following the instructions below. Note: both the .NET 3.5 and .NET 4.5 Frameworks are required. Do not install the .NET 3.5 Framework alone.


Manually add the .NET 3.5/4.5 Framework to Windows:


1. Open the Windows Control Panel | select Programs and Features.

2. Select the option to "Turn Windows features on or off"

3. In Windows 7 (or other Standard editions), you can select the .NET framework from the list and follow the steps for installation.

4. In Windows Server 2012 (and other Server editions), select the option to "Add roles and features," then Next. For Installation type, select "Role-based or feature-based installation," then Next. Choose your server from the Server Selection menu, then Next. Then choose the framework versions and complete the install.