5 Replies Latest reply on Feb 20, 2015 6:50 AM by aasim.shaikh@igate.com RSS
    aasim.shaikh@igate.com Explorer

    Axeda Desktop Viewer Ctrl-Alt-Del not working

    Hi,

     

    I am using Axeda Remote Desktop Viewer application to remotely access my asset. I am able to connect to the asset and view the asset desktop. However, I am unable to send Ctrl-Alt-Del command to asset. I tried using the control in the viewer's toolbar to send the command but it doesnt seem to work. There is no error but there is no effect either. E.g. if my asset's desktop is locked, I can not send Ctrl-Alt-Del to get to the login screen. After I do Ctrl-Alt-Del on the asset directly to bring up the login screen, I am able to key-in the login id and password from the remote viewer and I am able to control the desktop remotely. So, my only concern is to be able to send Ctrl-Alt-Del to the asset. Please suggest on how do I do it. Thanks.

     

    Regards,

    Aasim

      • Re: Axeda Desktop Viewer Ctrl-Alt-Del not working
        rthompson Creator

        Is the Axeda Desktop server running as a service?  I think it must be in order to execute a Ctl-Alt-Del. 

          • Re: Axeda Desktop Viewer Ctrl-Alt-Del not working
            lindahav Explorer

            From the Axeda Desktop Viewer's guide:

            "Important!To simulate Ctrl+Alt+Del (CAD) successfully, Axeda Desktop Server must be running as a service on Windows machines. If you cannot issue a CAD successfully and you know that the remote machine is running Windows, it may be that Desktop Server is not running as a service and/or that CAD has been disabled on that machine. CAD security can be disabled by a policy. Desktop Server provides a utility that a system administrator can run to resolve the problem, called setcad.exe."

             

            Please make sure ADS is running as a service. If it is, please look into CAD security as a possible solution.

              • Re: Axeda Desktop Viewer Ctrl-Alt-Del not working
                aasim.shaikh@igate.com Explorer

                Hi Randy, Linda

                 

                The Axeda Desktop Server is running as service on my system. As I said, after I manually do CAD on my system, I am able to remotely key-in the user id and password and also able to control the system remotely.

                 

                Linda,

                I could not find the setcad.exe file on my system. Could you please let me know where can I get it?

                 

                Regards,

                Aasim

                  • Re: Axeda Desktop Viewer Ctrl-Alt-Del not working
                    lindahav Explorer

                    Hello Aasim -

                    Again, this is from the Desktop Viewer's guide:

                    "The installer for Desktop Server runs a utility called setcad.exe, which should ensure that this group policy is set properly. If it is not working, run this utility on the machine. The utility is located in the Axeda/Desktop/Server/utils directory."

                     

                    please look for the utility in that location and update this tech forum with your progress!

                    thanks

                      • Re: Axeda Desktop Viewer Ctrl-Alt-Del not working
                        aasim.shaikh@igate.com Explorer

                        Hi Linda,

                         

                        Thanks for your prompt responses. I do not find utils directory in Axeda/Desktop/Server.

                         

                        I disabled CAD from "Manager User Accounts" dialog in Control Panel under "User Accounts". With that my system doesnt prompt for pressing CAD for login. Although it seems like a tweak to work around the problem of not being able to send CAD from Desktop Viewer, I have at least moved a step forward in working remotely on my asset. Thanks for your help.

                         

                        Regards,

                        Aasim