5 Replies Latest reply on Jan 17, 2017 5:09 AM by savinash RSS
    ewertonm Creator

    Error Installing ThingWorx

    For some reason I cannot install TW in my local machine anymore. I uninstalled Tomcat, cleared all caches, and deployed TW and still get an error message:


    HTTP Status 401 - Could not handle request


    type Status report

    message Could not handle request

    description This request requires HTTP authentication.


    Looking at Tomcat´s log I've found this:


    java.lang.NullPointerException

    at java.io.File.<init>(Unknown Source)

    at com.thingworx.extensibility.utils.ExtensionPackageUtilities.cleanJarDeploymentLocation(ExtensionPackageUtilities.java:1292)

    at com.thingworx.system.managers.ExtensionPackageManager.initializeCollection(ExtensionPackageManager.java:112)

    at com.thingworx.system.entities.ThingWorxEntityManager.initializeCollections(ThingWorxEntityManager.java:176)

    at com.thingworx.system.ThingWorxServer.Initialize(ThingWorxServer.java:110)

    at com.thingworx.system.ThingWorxBootstrapper.contextInitialized(ThingWorxBootstrapper.java:132)

    at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4710)

    at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5135)

    at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)

    at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:725)

    at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:701)

    at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:714)

    at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:917)

    at org.apache.catalina.startup.HostConfig$DeployWar.run(HostConfig.java:1701)

    at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)

    at java.util.concurrent.FutureTask.run(Unknown Source)

    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)

    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

    at java.lang.Thread.run(Unknown Source)

    *** CRITICAL ERROR ON STARTUP: Unable to initialize and start system: null


    PS: I tried many TW versions: 5.1, 5.2, 5.4 - all with the same results.


    Any idea of what could be happening?


    Thanks



      • Error Installing ThingWorx
        paic Collaborator

         

        One thought that comes to my mind is the fact that I've seen auto updates rolling out to Java 8, make sure your Tomcat is pointed to use the Java 7 jvm.

        Beyond that, not sure what OS you are using, but since you are starting clean, I would try the following:

         

        1. Stop tomcat

        2. Remove tomcat/webapps/thingworx and the thingworx.war

        3. Remove \ThingworxStorage and ThingworxBackupStorage

        4. If you are on a Linux type environment, recreate the two Storage folders and make sure full permissions are granted on them.


        Now start tomcat up and deploy Thingworx.



          • Error Installing ThingWorx
            scottmo Newbie

            I just had the same issue yesterday. Was going in circles trying to figure out what it was until a friend asked me about the ThingWorx Storage and ThingWorx Backup Storage folders. I had installed and removed TWX a few months ago, and they were still on my machine. To correct the problem, I removed the WAR file and TWX app from Tomcat, rebooted and then removed all occurrences of ThingworxStorage and ThingworxBackupStorage. After redeploying the WAR, the application ran as expected.

             



          • Error Installing ThingWorx
            ewertonm Creator

            Thanks guys.

             


            I did the same think but without being so conscious: unisntalled everything that was related (including Java) and installed again.



              • Re: Error Installing ThingWorx
                savinash Newbie

                Hi @Ewerton Moreira,

                 

                I also faced same issue in Thingworx, How i get out of it, Please find below steps to troubleshoot.

                 

                     1) Check Thingworx folder have permitted Windows/Linux directory access.

                     2) Validate Thingworx and Java both compatible version.

                     3) Hope u have created folder "Thingworx Platform" placed platform-settings.json as per installation document.

                     4) open platform-settings.json confirm that username and password

                                "password": "twadmin",

                                "username": "twadmin"

              • Re: Error Installing ThingWorx
                nicolasl Explorer

                I had the same issue with Thingworx 5.4
                In my case, I needed to move to Tomcat7 and Java7.

                 

                For Thingworx 6.x, Tomcat8 and Java8 are ok.

                 

                Thanks guys.