3 Replies Latest reply on Oct 15, 2015 8:54 AM by anderswi RSS
    anderswi Newbie

    "Ghost things" and failing export

    Hi,


    I created a bunch of things via scripting and for some reason some of them became invisible in the IDE. They do exist in the database somehow because when I try to create another thing with the same name Thingworx tells me that it already exists.


    When I try to delete or even access such a "ghost thing" from my script I get something similar to:


    Wrapped org.neo4j.graphdb.NotFoundException: Node 1567 not found Cause: Node 1567 not found


    I get the same error when trying to export my entities, so I can't really remove the /ThingworxStorage and start over :-(


    I'm using Thingworx 4.2.0 and Java 1.7.0_45 on a Mac


    Thanks,

    Anders



      • "Ghost things" and failing export
        anderswi Newbie

        I solved it by stopping and re-deploying Thingworx.

         

        • "Ghost things" and failing export
          paic Collaborator

          Hi Anders,

           


          Please be very careful in these situations.

          I believe we sort of stepped through this process, so I trust you are making sure that you are Enabling and Restarting your created Things before setting their Properties.


          Ghost things occur when you create Things through script and the script has a mistake in it somewhere after the Create or Clone Thing happens.


          Generally those indeed can be cleared out by clearing out the memory of the server i.e. restarting Thingworx or Tomcat. Please be careful though, if you restart by shutting down and starting up Tomcat, give it enough time to properly spin down and up Thingworx.


          If you need help with the script you are running let us know.



          • "Ghost things" and failing export
            anderswi Newbie

            Thanks Pai. You're right - I improved the error handling in my create script and it seem to have chased away the ghosts :)