6 Replies Latest reply on Oct 29, 2015 12:06 PM by avladescu RSS
    avladescu Explorer

    Thingworx 5.4 import issue

    Hi,

     

    I did a successful import of an entities file(size 500MB+) in 2h on a TW 5.4

    TW is running on Tomcat 7, using Java 7.

    But then when I searched for all the different stuff that was created(users,networks aso) I couldn't find anything in TW Platform.

    Any suggestions would be appreciated!

     

    Kind regards,

     

    Andrei Vladescu.

      • Re: Thingworx 5.4 import issue
        avladescu Explorer

        Ran the import again,having increased the Xmx option from 4g to 12g and I got an error:

         

        Unable to process import: Validation Failure: ThingTemplate BTThingTemplate Had An Invalid Parent Thing Template : [EdgeEnhanced]

        Internal error: java.lang.Exception: Import Failed: Validation Failure: ThingTemplate BTThingTemplate Had An Invalid Parent Thing Template : [EdgeEnhanced]

         

        Any  thoughts about it?

          • Re: Thingworx 5.4 import issue
            avladescu Explorer

            I imported AlwaysOn extension and then did a fresh import of the entities file and the error changed:

             

            Unable to process import: Validation Failure: Thing SysmexSmtpServer Had An Invalid Thing Template : [MailServer]

            Internal error: java.lang.Exception: Import Failed: Validation Failure: Thing SysmexSmtpServer Had An Invalid Thing Template : [MailServer]

             

            I imported the mail server extension as well. as the Solr extension and now the error is:

             

            [L: ERROR] [O: E.c.t.s.s.a.AlwaysOnSubsystem] [I: ] [U: Administrator] [S: ] [T: http-apr-80-exec-9]  (see error log details) [context: starting XMPP subsystem][message: Failed to start SOCKS5 proxy]

          • Re: Thingworx 5.4 import issue
            avladescu Explorer

            After a couple of stop-starts the alwaysOn subsystem started.I could check that with netstat -ano| find "1080"

            I started the import and it went fine till some point when the process stopped abbruptly.

             

            Error below:

             

            2015-10-28 18:57:59.397+0300 [L: ERROR] [O: E.c.t.s.s.a.AlwaysOnSubsystem] [I: ] [U: Administrator] [S: ] [T: http-apr-80-exec-6]  (see error log details) [context: starting XMPP subsystem][message: Failed to start SOCKS5 proxy] java.net.BindException: Cannot assign requested address: bind

            at sun.nio.ch.Net.bind0(Native Method) ~[na:1.7.0_79]

            at sun.nio.ch.Net.bind(Unknown Source) ~[na:1.7.0_79]

            at sun.nio.ch.Net.bind(Unknown Source) ~[na:1.7.0_79]

            at sun.nio.ch.ServerSocketChannelImpl.bind(Unknown Source) ~[na:1.7.0_79]

            at sun.nio.ch.ServerSocketAdaptor.bind(Unknown Source) ~[na:1.7.0_79]

            at org.apache.mina.transport.socket.nio.NioSocketAcceptor.open(NioSocketAcceptor.java:198) ~[mina-core-2.0.7.jar:na]

            at org.apache.mina.transport.socket.nio.NioSocketAcceptor.open(NioSocketAcceptor.java:51) ~[mina-core-2.0.7.jar:na]

            at org.apache.mina.core.polling.AbstractPollingIoAcceptor.registerHandles(AbstractPollingIoAcceptor.java:547) ~[mina-core-2.0.7.jar:na]

            at org.apache.mina.core.polling.AbstractPollingIoAcceptor.access$400(AbstractPollingIoAcceptor.java:68) ~[mina-core-2.0.7.jar:na]

            at org.apache.mina.core.polling.AbstractPollingIoAcceptor$Acceptor.run(AbstractPollingIoAcceptor.java:422) ~[mina-core-2.0.7.jar:na]

            at org.apache.mina.util.NamePreservingRunnable.run(NamePreservingRunnable.java:64) ~[mina-core-2.0.7.jar:na]

            at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [na:1.7.0_79]

            at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [na:1.7.0_79]

            Wrapped by: java.lang.RuntimeException: Failed to start SOCKS5 proxy

            at org.apache.vysper.xmpp.extension.xep0065_socks.Socks5Module.initialize(Socks5Module.java:143) ~[thingworx-vysper-0.8.5.jar:na]

            at org.apache.vysper.xmpp.server.DefaultServerRuntimeContext.addModule(DefaultServerRuntimeContext.java:317) ~[thingworx-vysper-0.8.5.jar:na]

            at org.apache.vysper.xmpp.server.XMPPServer.start(XMPPServer.java:211) ~[thingworx-vysper-0.8.5.jar:na]

            at com.thingworx.system.subsystems.alwayson.AlwaysOnSubsystem.startSubsystem(AlwaysOnSubsystem.java:739) ~[thingworx-alwaysonsubsystem-extension.jar:na]

            at com.thingworx.system.subsystems.Subsystem.startInternal(Subsystem.java:127) [thingworx-all-5.4.1.b9.jar:na]

            at com.thingworx.contentmanagement.ImportProcessor.processImport(ImportProcessor.java:891) [thingworx-all-5.4.1.b9.jar:na]

            at com.thingworx.webservices.Importer.service(Importer.java:108) [thingworx-all-5.4.1.b9.jar:na]

            at javax.servlet.http.HttpServlet.service(HttpServlet.java:731) [servlet-api.jar:na]

            at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:303) [catalina.jar:7.0.63]

            at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208) [catalina.jar:7.0.63]

            at org.apache.tomcat.websocket.server.WsFilter.doFilter(WsFilter.java:52) [tomcat7-websocket.jar:7.0.63]

            at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:241) [catalina.jar:7.0.63]

            at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208) [catalina.jar:7.0.63]

            at com.thingworx.security.authentication.AuthenticationFilter.propagateRequest(AuthenticationFilter.java:332) [thingworx-all-5.4.1.b9.jar:na]

            at com.thingworx.security.authentication.AuthenticationFilter.doFilter(AuthenticationFilter.java:139) [thingworx-all-5.4.1.b9.jar:na]

            at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:241) [catalina.jar:7.0.63]

            at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208) [catalina.jar:7.0.63]

            at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:220) [catalina.jar:7.0.63]

            at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:122) [catalina.jar:7.0.63]

            at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:505) [catalina.jar:7.0.63]

            at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:170) [catalina.jar:7.0.63]

            at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:103) [catalina.jar:7.0.63]

            at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:957) [catalina.jar:7.0.63]

            at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:116) [catalina.jar:7.0.63]

            at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:423) [catalina.jar:7.0.63]

            at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1079) [tomcat-coyote.jar:7.0.63]

            at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:620) [tomcat-coyote.jar:7.0.63]

            at org.apache.tomcat.util.net.AprEndpoint$SocketProcessor.doRun(AprEndpoint.java:2516) [tomcat-coyote.jar:7.0.63]

            at org.apache.tomcat.util.net.AprEndpoint$SocketProcessor.run(AprEndpoint.java:2505) [tomcat-coyote.jar:7.0.63]

            at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [na:1.7.0_79]

            at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [na:1.7.0_79]

            at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61) [tomcat-coyote.jar:7.0.63]

            at java.lang.Thread.run(Unknown Source) [na:1.7.0_79]

             

            Is there a timeout to be set or is it a bug?