2 Replies Latest reply on Feb 1, 2016 9:38 PM by khorie RSS
    khorie Newbie

    Modbus package:“filetransfer.lua are not found “

    Hi,

     

    I met the “filetransfer.lua are not found “ error when I run the luaSciptResouce in WS EMS + modbus package.

    It happens in both  Windows10 and Linux ARM (not HFPU.).

     

    So, I commented out the code of ‘require "thingworx.shapes.filetransfer" ’  in modbusExample.lua as temporally workaround,  Then, the IP packet of reading modbus slave were detected on WireShark. Also, the debug message showed the correct value of modbus register which are the same value in the external modbus salve node.

    Also, I searched “filetransfer.*“ file in /microserver folder, but it was not found.

     

    Did anyone see this error ?  If so, could you tell me how did you solved?

    Is  "filetransfer.lua" something like I should write the code as  custom application?

     

    I referred the following article, but it does not mention about the file "filetransfer.*".

    https://community.thingworx.com/community/developers/blog/2015/12/13/modbus-plc-simulator

     

    Exact error message

    mplates/modbusExample.lua:16: module 'thingworx.shapes.filetransfer' not found:

      no field package.preload['thingworx.shapes.filetransfer']

      no file 'C:/microserver/etc/thingworx/shapes/filetransfer.lua'

      no file 'C:/microserver/etc/thingworx/thingworx/shapes/filetransfer.lua'

      no file 'C:/microserver/etc/thingworx/lua/thingworx/shapes/filetransfer.lua'

      no file 'C:/microserver/etc/custom/thingworx/shapes/filetransfer.lua'

      no file 'C:/microserver/etc/custom/lua/thingworx/shapes/filetransfer.lua'

      no file 'C:/microserver/etc/community/lua/thingworx/shapes/filetransfer.lua'

      no file './thingworx/shapes/filetransfer.lua'

      no file 'C:/Thing

     

    I appreciate your any comment and/or advise.

    Thank you,

    Kunio