1 Reply Latest reply on Feb 18, 2016 1:30 PM by aanjan RSS
    patn Explorer

    PostgreSQL Version Compatibility

    Hi

     

    We just thought we would share this..

    If you are using an older LTS version of Ubuntu, such as 14.4 or 14.10, you will find Postgres 9.3 in the apt repositories.

     

    This will not work with ThingWorx!

     

    We didn't find any mention of Postgres supported versions in the install guides from 6.5.0 to 7.0.0 onwards, nor in the System Requirements documents. However, we have been answered by PTC Support directly that Postgres 9.3 is not supported. In fact, in Linux the two *.sg scripts used to create the ThingWorx database and default schemas will not execute properly.

    Postges 9.4 and later will be supported now and in the future.

     

    A few useful things...

    To update your Ubuntu apt repository to add postgres-9.4, check out this link:

    PostgreSQL: Linux downloads (Ubuntu)

     

     

    Install syntax:

    sudo apt-get install postgres-9.4

     

    Install the GUI admin tools:

    sudo apt-get install pgadmin3

     

    To connect to Postgres, change the default password and create the "twadmin" user, do the following:

    $ sudo -u postgres psql

     

         postgres=> alter user postgres password 'somePassword';

         postgres=> create user twadmin createdb createuser password 'otherPassword';

         postgres=> \q

     

    $ ...

     

    PS. Don't forget the ";" for the postgres commands

     

    Good luck!