10 Replies Latest reply on Jun 24, 2016 3:40 PM by dimmesoete RSS
    lwei Explorer

    User visibility

    Hi, developers!

    I have confront a problem.

     

    I created a organization and a user for it.

     

    But After logging in the organization, I can't see my background, my style definitions, only the widget's title.

     

    I have already set the visibility and the home mashup.

     

    Here is a awkward thing, after I add the user to the Administrators, it worked.

     

    I need some help, thank you!!

     

    Lee

      • Re: User visibility
        aanjan Heavyweight Champ

        Lee, try giving visibility permissions to the Platform Subsystem for that Organization.

          • Re: User visibility
            lwei Explorer

            Hi, Aanjan. I've tried your way to fix it.

            The mashup has showed some of the style definition, but some can't.

            And I have a question that the widgets in the mashup are no appearing,

            it only show the text, ex: button, mashup link, something like that.

          • Re: User visibility
            pchung Collaborator

            Besides what Aanjan recommends, there are also two services in the platform subsystem the user needs to be able to run, something along the lines of: GetDefaultStyleDefinitions and GetStateDefinitions?

            • Re: User visibility
              adrianpet Creator

                 In order to see the any entity on Thingworx with an user, you will need to grant that user the Visibility Permission. Also, in order to see that entity in the view mashup, you will need to grant the Run Time Permission. For example, in order to view and use a style definition in a mashup you will need to grant Visibility and Run Time.

              • Re: User visibility
                lwei Explorer

                Hi, everyone!

                I've tried all of your suggestions.

                1. Set the style definitions' permission.

                (When I use Administrator to view the mashup, the mashup shows correctly.

                But if I use a user to login to the organization, the mashup still can't show entities)

                2. I've saw the Application log, it appears a lot of "xxxx Entities not found"

                But the akward thing is that I 've already set the visibility and permission's to all entities.

                • Re: User visibility
                  dimmesoete Newbie

                  Thanks for this post.  I had a similar issue which was resolved by setting Visibility to the appropriate organization in the Platform Subsystem.