3 Replies Latest reply on Apr 29, 2016 11:40 AM by rshukla-2 RSS
    veronicamih Creator

    Problems connecting Intel Galileo Gen 2

    Hi

    This is Rahul, I am trying to learn using Thingworx Platform.But I am facing problem connecting Intel Galileo Gen 2 to your platform .

    I have followed the path that you have mentioned in the developer zone,but i am not able to run using winscp

    It seems that some steps are missing in the process.

    Can you provide me the any guide or guidance in this context.

     

    Thank You

    Rahul

      • Re: Problems connecting Intel Galileo Gen 2
        veronicamih Creator

        Hi Rahul,

         

        Have you connected your Intel Galileo to the Internet ? In order to connect to it using WinSCP you need to have an IP address for it.

        You would also need to use a ssh client like Putty to be able to run your agent on the Intel Galileo Board.

        There are also some connectivity settings to be done in the agent. Can you list the steps that you followed for setting up the project ?


        Thank you,


        Veronica

        • Re: Problems connecting Intel Galileo Gen 2
          rdholi Newbie

          Step6.png

           

           

           

           

           

           

           

           

           

           

           

           

           

           

           

           

           

           

           

           

           

           

           

           

           

           

           

           

          Yes I have connected Intel Galileo Gen 2 to the Internet via ethernet cable.I got IP address using PUTTY(operating in serial mode then "ifconfig" in command window ,I have used baud rate as 115200).I also tried getting IP address via this code:

           

          void setup() {

          }

          void loop() {

            system("ifconfig > dev/ttyGS0");

          sleep(10);

          }

           

          Both worked and gave same IP address.

          (I have followed the steps given on the Thingworx website)

          After that for copying files to Galileo I used Winscp l ,I configured following setting -File protocol-SCP ,HOST NAME-<IP address>,Username-root.

          Then after logging in ,inside home folder I created  a directory for the app named TWC_Agent.Copied files to to it from Install directory of TWC files(downloaded from thingworx website)

          Next step-

          In putty I used connection type as SSH,HOST NAME -<IP address>, port -22 and opened the connection

          then after logging in as root

          then I tried running :-    root@<ip address>

          it replied command not found

          then I tried ssh root@<ip address>

          It came to next line after some processing after this I tried to go into the directory where the files were copied by  "cd TWC_Agent"

          The on next line when I gave command to run agent as " ./twc_agent"     to which it replied permission denied.

          I have attached the image where i am facing problem.

           

          I don't know where i have gone wrong.