5 Replies Latest reply on Mar 28, 2016 3:54 PM by rchiacchiaro RSS
    rchiacchiaro Newbie

    Composer Tutorial Crashes

    Hey, I just started looking into ThingWorx and was running the basic tutorial for the Composer (which I thought was Connected Car but might actually be for an assembly line?). I got partway through and had to step away for a bit. When I returned, I was prompted for my login credentials again, but they could not be authenticated (even though they're the same ones I've been using to log in this whole time). I exited the tutorial and tried to relaunch it, but now I'm unable to navigate through the guide. I'm stuck on Step 1: Click the "Home" tab, and clicking "Next" does nothing, so it seems that tutorial mode has been deactivated and I am left with a sandbox environment. Any idea how to reactivate the tutorial, or why my login wasn't working? The documentation/community forums don't seem to have anything on the tutorials.

     

    Thanks!

      • Re: Composer Tutorial Crashes
        rchiacchiaro Newbie

        As an update, I tried the same thing in the Connected Devices tutorial. Again, after an idle period, I was given a pop-up from ThingWorx making me log in again but not accepting my credentials. However, when I exited the tutorial and relaunched, my progress had been saved as expected and I was able to continue without error.

          • Re: Composer Tutorial Crashes
            aanjan Heavyweight Champ

            Rhiannon, are you just stuck on the first tutorial then? The default user idle session timeout is set at 30 minutes, hence the reason why you got logged out.

              • Re: Composer Tutorial Crashes
                rchiacchiaro Newbie

                Yes, the first one labeled ThingWorx Tour (apologies, I thought it was Connected Car but that seems to be working now). After the 30 minute timeout, I'm given a popup saying that I need to log in and my session is not private. However, entering my confirmed login credentials does not log me back in, but instead drops the popup down again as if I had never entered them in the first place. Cancelling out of the popup leads to the server error page for an invalid login. When this happened with the Connected Devices tutorial, I was able to exit out and rejoin, which saved my work and let me continue. In the Tour, it froze back on step one, though now when I try to enter it, I don't get any tutorial and it tells me I completed the tutorial even though I didn't.