8 Replies Latest reply on Apr 17, 2016 6:13 PM by gsee RSS
    gsee Apprentice

    Organization login

    I've created a new organization, mashup, and form login. However, when I go to the page <server name>/Thingworx/FormLogin/NewOrganization and log in as any user within that organization, I get a blank page at http://<server name>/Thingworx/action-login. I've tried adding the new mashup as the home for the individual users and adjusting the visibility settings, but I haven't been able to find a solution to this. Any help would be great, thanks!

      • Re: Organization login
        aanjan Heavyweight Champ

        Gloria, what version of ThingWorx are you using? You should be forwarded to the set homepage via the action-login. Do you have a default Home Mashup set at the Organization level? Can you try again after setting one?

          • Re: Organization login
            gsee Apprentice

            Hi Aanjan,

             

            I'm using 6.6. Under the Organization General Information, I have set the TestOrganizationMashup as the home mashup. That was the first configuration that I tried, but I've yet to have anything show up after the login portal.

              • Re: Organization login
                aanjan Heavyweight Champ

                Once the login stalls at the action-login page, can you try going to Thingworx/Composer/index.html in a new tab? Do you have to re-authenticate or does it load? Just to check, you are testing these on a private/ incognito window, so that the sessions are different, right?

                  • Re: Organization login
                    gsee Apprentice

                    I'm doing all the new organization testing in an incognito window.

                     

                    I had something new happen this time... 

                    Status message: Could not load "NewOrganizationMashup". Reason: 404 - Entity Not Found : [NewOrganizationMashup]

                     

                    When I went to the composer index, I was asked to accept the license agreement, and then the composer loaded, but with no entities/organizations/users visible anywhere, including the mashups that are set to be home mashups and visible to the test user (set by the Admin user).

              • Re: Organization login
                gsee Apprentice

                Thanks, that worked when I added the User to the Run Time permissions, but not when I had added the User's Organization to the visibility permissions. I can only add organizations, not users or groups to visibility. Will I need to do this manually for each user with access to the organization's mashup?

                  • Re: Organization login
                    aanjan Heavyweight Champ

                    Gloria, you can use User Groups instead; in that way you can categorize and assign users into different groups, and apply the overall runtime permissions on a group level.

                      • Re: Organization login
                        gsee Apprentice

                        Thanks for the help. I also realized that since I'm using a distinct master for this organization, I needed to set visibility permissions for both the master and the mashup for it to load correctly.