1 Reply Latest reply on Aug 26, 2016 3:02 PM by brue RSS
    rwang Newbie

    REST-API "Access-Control-Allow-Origin" problem

    Hi everyone,

    I want to call REST-API from Thingworx to my web server,and I have an error occur "No 'Access-Control-Allow-Origin' header is present on the requested resource. ".

     

    After I added following settings to my web.xml file , I can solve "Access-Control-Allow-Origin" error ,But I met another problem is that I can't delete Entity(ex:Thing) from my Thingworx. Does anyone have the same problem ? Could give me some suggestion about that? Thank you.

     

    <filter>

      <filter-name>CorsFilter</filter-name>

      <filter-class>org.apache.catalina.filters.CorsFilter</filter-class>

      <init-param>

        <param-name>cors.allowed.origins</param-name>

        <param-value>*</param-value>

      </init-param>

      <init-param>

        <param-name>cors.allowed.methods</param-name>

        <param-value>GET,POST,HEAD,OPTIONS,PUT</param-value>

      </init-param>

      <init-param>

        <param-name>cors.allowed.headers</param-name>

        <param-value>Content-Type,X-Requested-With,accept,Origin,Access-Control-Request-Method,Access-Control-Request-Headers</param-value>

      </init-param>

      <init-param>

        <param-name>cors.exposed.headers</param-name>

        <param-value>Access-Control-Allow-Origin,Access-Control-Allow-Credentials</param-value>

      </init-param>

      <init-param>

        <param-name>cors.support.credentials</param-name>

        <param-value>true</param-value>

      </init-param>

      <init-param>

        <param-name>cors.preflight.maxage</param-name>

        <param-value>10</param-value>

      </init-param>

    </filter>

    <filter-mapping>

      <filter-name>CorsFilter</filter-name>

      <url-pattern>/*</url-pattern>

    </filter-mapping>

     

     

    Many thanks