21 Replies Latest reply on Mar 23, 2017 1:38 AM by psaxena RSS
    tnayyar Creator

    Thingworx not running

    Hi,

     

    I'm trying to run Thingworx runtime as usual using URL but I'm getting a blank white page with no errors.Seems like Thingworx runtime page is loaded but Invisible.

    Also tried to run Composer page but again no luck.Even tried to run Thingworx composer from Tomcat Apache console but same blank page after passing username and password for Authentication.

     

    I had a RAM upgrade since its last working time but I guess that should not hamper Thingworx runtime/composer.

     

    Its a new kind of issue to me.Did anyone ever faced this same issue or anyone has comments on this?

      • Re: Thingworx not running
        horia.raducioiu Apprentice

        Hi Tarun,

        I would check the following paths:

        - Check that the Tomcat service is running and that the Tomcat process is alive

        - Check the ThingworxStorage / logs folder for any ThingWorx related errors

        - Check the Tomcat_root / logs for any Tomcat related errors

        Let me know what you've find on the logs.

          • Re: Thingworx not running
            tnayyar Creator

            Hi Horia,

             

            Tomcat is running and alive. I checked into logs of Tomcat & Thingworx and found below information.

             

            -Error log of Thingworx

            at com.mchange.v2.c3p0.impl.NewProxyPreparedStatement.execute(NewProxyPreparedStatement.java:1392) ~[c3p0-0.9.5.jar:0.9.5]

              at com.thingworx.persistence.postgres.PostgresDocumentModelDriver.removeFileTransferJobs(PostgresDocumentModelDriver.java:1066) ~[thingworx-platform-postgres-7.0.0-b2.jar:na]

            Wrapped by: com.thingworx.common.exceptions.ModelAccessException: [2,002] No connection. Contact the administrator.

             

            - Application logs of Thingowrx

            [L: INFO] [O: c.t.s.ThingWorxServer] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Starting All Things...

            [L: INFO] [O: c.t.s.ThingWorxServer] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Activating Subscriptions...

            [L: INFO] [O: c.t.s.ThingWorxServer] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Activating Property Bindings...

            [L: INFO] [O: c.t.s.ThingWorxServer] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Sending Post Start Notifications...

            [L: INFO] [O: c.t.s.ThingWorxServer] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Thingworx Server Application...ON

            [L: INFO] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Datastore database...INITIALIZED

             

            Seems everything initialized and started as expected and didn't find any severe error/warning in logs.

             

            Note : found one memory leak log as:

            SEVERE [localhost-startStop-1] org.apache.catalina.loader.WebappClassLoaderBase.checkThreadLocalMapForLeaks The web application [Thingworx] created a ThreadLocal with key of type [java.lang.ThreadLocal] (value [java.lang.ThreadLocal@67b1b2f9]) and a value of type [java.util.Stack] (value [[SuperUser:User]]) but failed to remove it when the web application was stopped. Threads are going to be renewed over time to try and avoid a probable memory leak.

          • Re: Thingworx not running
            Ravi Upadhyay Communicator

            Tarun Nayyar Are you using mysql database in backend ? 

            • Re: Thingworx not running
              Ravi Upadhyay Communicator

              ModelAccessException: [2,002] No connection :

               

              In your case it looks like Your DB has not started as you are getting the message that indicates there is no server running and therefore listening for requests.

               

              Look at the postgres log and if that tells you nothing look at the Windows event log, in the 'Windows -> Applications` section. Error messages in there are pretty good at identifying the cause of Db failing to start.

              • Re: Thingworx not running
                Ravi Upadhyay Communicator

                Aanjan Ravi , I think its related to databases not started or some configuration issues , wherein port number or server details might not  be in correct , Please let me  know your views as well , as

                ModelAccessException: [2,002] No connection : is definitely Db not responding.


                Durgesh Patel We faced this issue with one of our client , whose db was not properly set up , would you like to add something as well  and we resolved it .

                • Re: Thingworx not running
                  kmoon Apprentice

                  Which version of a web browser are you using?

                  • Re: Thingworx not running
                    psaxena Creator

                    Hi Pai Chung,

                    I did face the same issue and it was resolved after deleting the ThingworxStorage and ThingworxBackupStorage folders. But how do i get these folders back i.e do i need to recreate them? and what about the data in these folders.

                      • Re: Thingworx not running
                        Ankit Gupta Ninja

                        Hi Priyanshi Saxena, Did you take a backup of these folders before deleting them. It is always recommended to take backup.

                        Also, what was the error in logs? Deleting the folders should be the last option but in general we should actually check the logs to find out the Root cause.

                        After deleting these folders all the data will be lost for Neo4j and H2 Database. The ThingworxStorage and ThingworxBackupStorage folders will be auto created again but it will behave like a new instance.

                        In case of Postgresql; their will be some inconsistency as the extensions are available in these folders and their will be entities based on these extensions in the Database which will cause null pointer exception.

                        So, in short always delete with caution and always make sure to take a backup of whatever we want to delete.