6 Replies Latest reply on Dec 30, 2016 9:10 AM by supandey RSS
    kchien Newbie

    cannot delete and import GoogleWidgets_ExtensionPackage

    dear sir,

    I follow ThingWorx Foundation QuickStart steps on my 30 day foundation server,I bind  'house_lat_long' to the 'SelectedLocation' on the googlemap widget ,view mashup then I got 'MissingKeyMapError' in my chrome client.

    so I want to delete the extension 'GoogleWidgets_ExtensionPackage' and import to update its api key,like this:

    <FileResource type="JS" url="https://maps.google.com/maps/api/js?key=[my api key]&amp;sensor=false" description="" isDevelopment="false" isRuntime="true" />


    but when I try to delete the extension , I got this ,should I delete the dependencies first??

    Extension Package deletion failed: Unable to Invoke Service DeleteExtensionPackage on PlatformSubsystem : Cannot delete ExtensionPackage [GoogleWidgets_ExtensionPackage] because the following ExtensionPackages depend on it: [TWX_Converge_Core_ExtensionPackage]