14 Replies Latest reply on Feb 3, 2017 9:49 AM by giri RSS
    srathoud Explorer

    Multiple Issues with Thingworx Studio

    Hi,

     

    I am facing few problems with Thingworx Studio

     

    When I lauch the Thingworx Studio the welcome screen shows error as "Error occurred, check logs". I am not sure why this is happening.

    When I open Thingworx Studio. I can still see my earlier created projects, but I can't load them and when I try to create new one, even that is not working. I can see window as shown bleow:

    Please find the logs below:

    [16:00:34] Studio Version 1.8 (0.1.12.1082)

    [16:00:34] Status Message: Version 1.8 (0.1.12.1082)

    [16:00:34] Checking for updates from https://studio-download.vuforia.io/downloads/ThingworxMobileBuilderApp.application

    [16:00:43] Starting node.exe

    [16:00:43] debug: [twx-studio:logging] Debug logging enabled. DEBUG=twx-studio*,ar-extension*

    [16:00:43] Mon, 16 Jan 2017 10:30:43 GMT twx-studio:logging DEBUG_FD=1 so the "debug" module will log to stdout instead of stderr

    [16:00:43] info: [twx-studio:initializer] Node version: 6.9.1

    [16:00:43] debug: [twx-studio:initializer] ThingWorxStudio dir:  C:\Users\sameergr\Documents\ThingWorxStudio

    [16:00:43] debug: [twx-studio:initializer] Projects dir:  C:\Users\sameergr\Documents\ThingWorxStudio\Projects

    [16:00:43] debug: [twx-studio:initializer] Extensions dir:  C:\Users\sameergr\Documents\ThingWorxStudio\Extensions

    [16:00:43] debug: [twx-studio:initializer] ThingMarks dir:  C:\Users\sameergr\Documents\ThingWorxStudio\ThingMarks

    [16:00:43] debug: [twx-studio:initializer] Move /VuforiaStudioEnterpriseExtensions

    [16:00:43] (node:3212) DeprecationWarning: `DEBUG_FD` is deprecated. Override `debug.log` if you want to use a different log function (https://git.io/vMUyr)

    [16:00:43] debug: [twx-studio:fileUtils] C:\Users\sameergr\Documents\VuforiaStudioEnterpriseExtensions does not need to be moved, it does not exist

    [16:00:43] debug: [twx-studio:initializer] Move the projects dir

    [16:00:43] debug: [twx-studio:fileUtils] C:\Users\sameergr\Documents\VuforiaStudioEnterpriseProjects does not need to be moved, it does not exist

    [16:00:43] debug: [twx-studio:initializer] Initialize builderSettings

    [16:00:43] debug: [twx-studio:index] Done with initialization

    [16:00:44] debug: [twx-studio:index] Startup process.argv is ["C:\\Users\\sameergr\\AppData\\Local\\Apps\\2.0\\AGQK50HY.2AK\\ZWH4JWZ8.0LW\\thin..udio_cd45769e4d993f77_0000.0001_b83b4d91f9311a36\\node.exe","C:\\Users\\sameergr\\AppData\\Roaming\\ThingworxStudio\\studio-download.vuforia.io\\dist\\server\\index.js","C:\\Users\\sameergr\\Documents"]

    [16:00:44] debug: [twx-studio:extension-manager] extensionName to require ves-ar-extension

    [16:00:44] ar-extension version 1.8.290

    [16:00:44] debug: [twx-studio:extension-manager] extensionName to require ves-basic-web-widgets-extension

    [16:00:44] debug: [twx-studio:extension-manager] extensionName to require ves-sample-projects

    [16:00:44] debug: [twx-studio:extension-manager] extensionName to require twx-data-provider

    [16:00:44] debug: [twx-studio:projectHelper] ["C:\\Users\\sameergr\\AppData\\Roaming\\ThingworxStudio\\studio-download.vuforia.io\\node_modules\\ves-ar-extension\\node_modules\\lodash\\index.js"]

    [16:00:44] info: [twx-studio:index] *********** Preview listening on 127.0.0.1:4001

    [16:00:44] info: [twx-studio:index] listening on 127.0.0.1:3000

    [16:00:46] Proxying: http://localhost:3000

    [16:00:46] Access URLs:

    [16:00:46]  ----------------------------

    [16:00:46]  Local: http://localhost:3001

    [16:00:46]  ----------------------------

    [16:00:46] Watching files...

    [16:00:46] Proxying: http://localhost:4001

    [16:00:46] Access URLs:

    [16:00:46]  ----------------------------

    [16:00:46]  Local: http://localhost:4000

    [16:00:46]  ----------------------------

    [16:00:47] debug: [twx-studio:sockets] a user connected

    [16:01:10] debug: [twx-studio:sockets] a user connected

    [16:01:10]  [0mGET /%7B%7BprojectType.imgPath%7D%7D  [32m200  [0m5.223 ms - 2122 [0m

    [16:01:10]  [0mGET /%7B%7Bview.imgPath%7D%7D  [32m200  [0m4.737 ms - 2122 [0m

    [16:01:10]  [0mGET /%7B%7BviewType.imgPath%7D%7D  [32m200  [0m4.254 ms - 2122 [0m

    [16:01:10]  [0mGET /images/%7B%7Bw.name%7D%7D.png  [32m200  [0m4.192 ms - 2122 [0m

    [16:01:10] debug: [twx-studio:sockets] EMIT builderSettings

    [16:01:10] debug: [twx-studio:sockets] EMIT updateProjects

    [16:01:10] debug: [twx-studio:sockets] EMIT updateProjects

    [16:01:12] debug: [twx-studio:sockets] EMIT getProjectTypes

    [16:01:16] debug: [twx-studio:projectHelper] Copying /src/**/* to project, overwrite=false

    [16:01:16] debug: [twx-studio:projectHelper] Copying /**/* to project, skip /src/**/*,  overwrite=true

    [16:01:16] debug: [twx-studio:projectHelper] Symlink node_modules

    [16:01:16] debug: [twx-studio:projectHelper] Copy of project files complete

    [16:01:16] debug: [twx-studio:projectSettings] write project settings FacilityPlantNew

    [16:01:16] debug: [twx-studio:utility:runProjectGulpTask] C:\Users\sameergr\AppData\Local\Apps\2.0\AGQK50HY.2AK\ZWH4JWZ8.0LW\thin..udio_cd45769e4d993f77_0000.0001_b83b4d91f9311a36\node.exe C:\Users\sameergr\AppData\Roaming\ThingworxStudio\studio-download.vuforia.io\node_modules\gulp\bin\gulp.js init cwd=C:\Users\sameergr\Documents\ThingWorxStudio\Projects\FacilityPlantNew

    [16:01:17] info: [twx-studio:utility:runProjectGulpTask] [16:01:17] Using gulpfile ~\Documents\ThingWorxStudio\Projects\FacilityPlantNew\gulpfile.js

    [16:01:17] Starting 'init-src'...

    [16:01:17] Finished 'init-src' after 1.47 ms

    [16:01:17] Starting 'init'...

    [16:01:17] Finished 'init' after 8.96 μs

    [16:01:17]

    [16:01:17] error: [twx-studio:utility:runProjectGulpTask] (node:7124) DeprecationWarning: `DEBUG_FD` is deprecated. Override `debug.log` if you want to use a different log function (https://git.io/vMUyr)

    [16:01:17]

    [16:01:17] debug: [twx-studio:projectHelper] buildApp FacilityPlantNew

    [16:01:17] debug: [twx-studio:projectHelper] write settings

    [16:01:17] debug: [twx-studio:projectSettings] write project settings FacilityPlantNew

    [16:01:17] debug: [twx-studio:projectHelper] copy runtime extensions

    [16:01:17] debug: [twx-studio:projectHelper] packageThemeSet

    [16:01:17] debug: [twx-studio:themeManager] generating studio-designtime-vars.scss

    [16:01:17] debug: [twx-studio:themeManager] generating studio-runtime-vars.scss

    [16:01:17] debug: [twx-studio:themeManager] processThemes

    [16:01:17] debug: [twx-studio:themeManager] Making theme:  twx-light , includePaths:  C:\Users\sameergr\AppData\Roaming\ThingworxStudio\studio-download.vuforia.io\node_modules\ves-ar-extension\src\ar\src-scaffold\ionic\scss

    [16:01:17] debug: [twx-studio:themeManager] Building twx-light-theme-designtime.css

    [16:01:17] debug: [twx-studio:themeManager] Making theme:  twx-dark , includePaths:  C:\Users\sameergr\AppData\Roaming\ThingworxStudio\studio-download.vuforia.io\node_modules\ves-ar-extension\src\ar\src-scaffold\ionic\scss

    [16:01:17] debug: [twx-studio:themeManager] Building twx-dark-theme-designtime.css

    [16:01:17] debug: [twx-studio:themeManager] Building twx-dark-theme.css

    [16:01:17] debug: [twx-studio:themeManager] Building twx-light-theme.css

    [16:01:18] debug: [twx-studio:themeManager] building system-widget-extensions-designtime.css

    [16:01:18] debug: [twx-studio:themeManager] building app-designtime.css

    [16:01:18] debug: [twx-studio:themeManager] building app.css

    [16:01:18] debug: [twx-studio:themeManager] building system-widget-extensions.css

    [16:01:18] debug: [twx-studio:themeManager] copying css files for selected theme twx-light

    [16:01:18] debug: [twx-studio:projectHelper] onBuild

    [16:01:18] info: [twx-studio:projectHelper] Building ves-ar-extension app: FacilityPlantNew

    [16:01:18] Mon, 16 Jan 2017 10:31:18 GMT ar-extension:gulp-shared clean

    [16:01:18] debug: [twx-studio:projectHelper] pathDir C:\Users\sameergr\Documents\ThingWorxStudio\Projects\FacilityPlantNew

    [16:01:18] debug: [twx-studio:projectHelper] scaffoldDir C:\Users\sameergr\Documents\ThingWorxStudio\Projects\FacilityPlantNew\src-scaffold

    [16:01:18] debug: [twx-studio:projectHelper] copySrc

    [16:01:18] Mon, 16 Jan 2017 10:31:18 GMT ar-extension:gulp-shared copySrc

    [16:01:18] debug: [twx-studio:projectHelper] buildApp

    [16:01:18] Mon, 16 Jan 2017 10:31:18 GMT ar-extension:gulp-shared build

    [16:01:18] Reloading Browsers...

    [16:01:18] debug: [twx-studio:sockets] EMIT addProjectComplete

    [16:01:18] debug: [twx-studio:sockets] EMIT updateProjects

    [16:01:18] Mon, 16 Jan 2017 10:31:18 GMT ar-extension:gulp-shared compile view contents

    [16:01:18] no script for Home

    [16:01:18] debug: [twx-studio:sockets] EMIT updateProjects

    [16:01:18] debug: [twx-studio:sockets] user disconnected

    [16:02:23]  [0mGET /design/FacilityPlantNew  [32m200  [0m0.977 ms - 2122 [0m

    [16:02:23] debug: [twx-studio:sockets] user disconnected

    [16:02:24] debug: [twx-studio:sockets] a user connected

    [16:02:24]  [0mGET /%7B%7BviewType.imgPath%7D%7D  [36m304  [0m0.450 ms - - [0m

    [16:02:24]  [0mGET /images/%7B%7Bw.name%7D%7D.png  [36m304  [0m1.257 ms - - [0m

    [16:02:24] debug: [twx-studio:sockets] EMIT builderSettings

    [16:02:24] debug: [twx-studio:sockets] EMIT updateProjects

    [16:02:24] debug: [twx-studio:upgradeProject] upgradeIfNeeded FacilityPlantNew

    [16:02:24] Mon, 16 Jan 2017 10:32:24 GMT ar-extension:upgrade No upgrade needed:  1.8.290 1.8.290

    [16:02:24] debug: [twx-studio:upgradeProject] Project does not need an upgrade.

    [16:02:24] debug: [twx-studio:projectSettings] write project settings FacilityPlantNew

     

    Please help me with the same.