7 Replies Latest reply on Apr 6, 2017 3:02 AM by mwassmann RSS
    tlichtenberger-2 Apprentice

    Error CAD converter failed

    Hey there!

     

    I am currently working with Thingworx Studio and I have come across the following problem:

     

    I wanted to upload a .stp file (STEP) which should be supported by thingworx Studio. But when I want to add it, it fails.

    I have already tried to add it with the Run CAD Optimizer Option ticked, but I got the sam error as well.

    The size of the 3D shouldnt be the problem as I have already tested it with a smaller one and that failed as well.

     

    Any suggestions?

     

    P.s.: If you want to see the log files, you will have to tell me where to get them because I have no clue where to find them. Thank you so much

    in advance

     

    Message was edited by: Sushant Pandey moving the thread to ThingWorx Studio page for better visibility as the question is on ThingWorx Studio.

      • Re: Error CAD converter failed
        Ankit Gupta Ninja

        Theresa Lichtenberger,

         

        The logs are accessible from the ThingWorx Studio application window. You will find 'View Logs' link on the bottom-right of the window.

         

          • Re: Error CAD converter failed
            rolandr Explorer

            Hi,

            I tested also the issue with Thingworx - version:

            Created a simple file form Creo Parametric model and exported it to step

            And added to resources in Thingworx 'Studio. I selected the option optimize. So the results is that it created pvz models with high low and medium .

             

            So I believe may be you need to check the step file if it is ok and could be retrieved in any other tools - for example in PTC Creo Prametric. I used for the test Creo Parametric 4.0 M010


          • Re: Error CAD converter failed
            mwassmann Apprentice

            Hej Theresa,

             

            are you able to share that step-file?

             

            Thanks

            Martin

            • Re: Error CAD converter failed
              dtsarev Explorer

              Theresa

               

              Is it a new installation or things used to work before?

              Can you successfully upload a .pvz with "Run Optimizer" checkbox ticked, or seeing similar "CAD Optimization failed" error?

               

              I have seen similar issue on a PC with missing / broken Visual C++ Redistributable. Just got it from the link below and installed - the issue was gone in 5 min. Download Visual C++ Redistributable für Visual Studio 2015 from Official Microsoft Download Center

              • Re: Error CAD converter failed
                tlichtenberger-2 Apprentice

                Hi Dmitry Tsarev , Martin Wassmann , Roland Raytchev , Ankit Gupta ,

                 

                I am afraid I am not able to share the stp file but I also tried it with an .igs file and had the same Problem.

                 

                But I can Show you my log file, maybe it can give you any clue what is going on:

                 

                [06:41:21] Studio Version 1.10 (0.1.14.1237)

                [06:41:21] Status Message: Version 1.10 (0.1.14.1237)

                [06:41:21] Checking for updates from https://studio-download.vuforia.io/downloads/ThingworxMobileBuilderApp.application

                [06:41:22] Starting node.exe

                [06:41:31] info: [twx-studio:initializer] Node version: 6.9.1

                [06:41:31] info: [twx-studio:initializer] ThingWorxStudio launched with the following arguments: _=[C:\Users\t_lichtenberger\Documents], $0=..\..\..\..\..\..\Roaming\ThingworxStudio\studio-download.vuforia.io\dist\server\index.js

                [06:41:31] info: [twx-studio:initializer] ThingWorxStudio dir:  C:\Users\t_lichtenberger\Documents\ThingWorxStudio , home dir: C:\Users\t_lichtenberger\Documents

                [06:41:45] ar-extension version 1.10.358

                [06:41:46] info: [twx-studio:index] *********** Preview listening on 127.0.0.1:4001

                [06:41:46] info: [twx-studio:index] listening on 127.0.0.1:3000

                [06:41:50] Proxying: http://localhost:4001

                [06:41:50] Access URLs:

                [06:41:50]  ----------------------------

                [06:41:50]  Local: http://localhost:4000

                [06:41:50]  ----------------------------

                [06:41:52] Proxying: http://localhost:3000

                [06:41:52] Access URLs:

                [06:41:52]  ----------------------------

                [06:41:52]  Local: http://localhost:3001

                [06:41:52]  ----------------------------

                [06:41:52] Watching files...

                [06:47:49]  [0mGET /%7B%7BprojectType.imgPath%7D%7D  [32m200  [0m9.802 ms - 2035 [0m

                [06:47:49]  [0mGET /%7B%7Bview.imgPath%7D%7D  [32m200  [0m9.241 ms - 2035 [0m

                [06:47:49]  [0mGET /%7B%7Bconstraint.imgPath%7D%7D  [32m200  [0m9.502 ms - 2035 [0m

                [06:47:49]  [0mGET /%7B%7BviewType.imgPath%7D%7D  [32m200  [0m0.968 ms - 2035 [0m

                [06:47:49]  [0mGET /images/%7B%7Bw.name%7D%7D.png  [32m200  [0m0.934 ms - 2035 [0m

                [06:48:14]  [0mGET /images/%7B%7Bwidget.type%7D%7D.png  [32m200  [0m1.866 ms - 2035 [0m

                [06:48:32]  [0mGET /images/%7B%7Bwidget.type%7D%7D.png  [36m304  [0m0.689 ms - - [0m

                [06:48:32]  [0mGET /images/%7B%7Bwidget.type%7D%7D.png  [36m304  [0m0.635 ms - - [0m

                [06:48:32]  [0mGET /images/%7B%7Bwidget.type%7D%7D.png  [36m304  [0m0.652 ms - - [0m

                [06:48:41]  [0mGET /images/%7B%7Bwidget.type%7D%7D.png  [36m304  [0m0.482 ms - - [0m

                [06:48:41]  [0mGET /images/%7B%7Bwidget.type%7D%7D.png  [36m304  [0m0.432 ms - - [0m

                [06:48:41]  [0mGET /images/%7B%7Bwidget.type%7D%7D.png  [36m304  [0m0.481 ms - - [0m

                [06:48:41]  [0mGET /images/vse-3d-model.etb  [32m200  [0m1.135 ms - 2035 [0m

                [06:48:41]  [0mGET /images/%7B%7Bwidget.type%7D%7D.png  [36m304  [0m0.756 ms - - [0m

                [06:48:41]  [0mGET /images/%7B%7Bwidget.type%7D%7D.png  [36m304  [0m0.440 ms - - [0m

                [06:48:41]  [0mGET /images/%7B%7Bwidget.type%7D%7D.png  [36m304  [0m1.135 ms - - [0m

                [06:49:44] info: [twx-studio:resourceService] converter stdout:

                [06:49:44] info: [twx-studio:resourceService] Error running converter:  Error: Command failed: C:\Users\t_lichtenberger\AppData\Roaming\ThingworxStudio\studio-download.vuforia.io\dist\server\services/../../../node_modules/cad-import-filters/import_filters/win64/bin/step2pv.exe -vc1 -p C:\Users\t_lichtenberger\Documents\ThingWorxStudio\Projects\Waliclean\src\phone\resources\Uploaded -o WLC1 -r C:\Users\t_lichtenberger\AppData\Roaming\ThingworxStudio\studio-download.vuforia.io\dist\server\services/../../../node_modules/cad-import-filters/import_filters/win64/recipe/step2pv_import3d_dt.rcp C:\Users\t_lichtenberger\Documents\ThingWorxStudio\Projects\Waliclean\src\phone\resources\Uploaded\WLC1.stp

                [06:49:44]

                [06:49:44]     at ChildProcess.exithandler (child_process.js:206:12)

                [06:49:44]     at emitTwo (events.js:106:13)

                [06:49:44]     at ChildProcess.emit (events.js:191:7)

                [06:49:44]     at maybeClose (internal/child_process.js:877:16)

                [06:49:44]     at Socket.<anonymous> (internal/child_process.js:334:11)

                [06:49:44]     at emitOne (events.js:96:13)

                [06:49:44]     at Socket.emit (events.js:188:7)

                [06:49:44]     at Pipe._handle.close [as _onclose] (net.js:498:12)

                [06:49:44]  [0mPOST /api/app_resource  [31m500  [0m46665.535 ms - 22 [0m

                 

                 

                Thank you so much in advance for your help