1 Reply Latest reply on Apr 28, 2017 1:13 PM by polinao RSS
    atiwari-2 Newbie

    While installing thingworks plugin in eclipse getting conflict .

    Hi,

    I downloaded plugin from ThingWorks market place "" but  when i am trying to install it on eclipse Juno. Getting below error.

     

    Cannot complete the install because of a conflicting dependency.

      Software being installed: ThingWorx Extension Builder 7.2.0.201608021836 (com.thingworx.eclipse.extension.feature.feature.group 7.2.0.201608021836)

      Software currently installed: Eclipse IDE for Java EE Developers 1.5.1.20120917-1257 (epp.package.jee 1.5.1.20120917-1257)

      Only one of the following can be installed at once:

        Core Runtime 3.10.0.v20140318-2214 (org.eclipse.core.runtime 3.10.0.v20140318-2214)

        Core Runtime 3.8.0.v20120912-155025 (org.eclipse.core.runtime 3.8.0.v20120912-155025)

        Core Runtime 3.8.0.v20120521-2346 (org.eclipse.core.runtime 3.8.0.v20120521-2346)

      Cannot satisfy dependency:

        From: ThingWorx Extension Builder 7.2.0.201608021836 (com.thingworx.eclipse.extension.feature.feature.group 7.2.0.201608021836)

        To: org.eclipse.core.runtime 3.10.0

      Cannot satisfy dependency:

        From: Eclipse IDE for Java EE Developers 1.5.1.20120917-1257 (epp.package.jee 1.5.1.20120917-1257)

        To: org.eclipse.epp.package.jee.feature.feature.group [1.5.1.20120917-1257]

      Cannot satisfy dependency:

        From: Eclipse e4 Rich Client Platform 1.1.0.v20120521-2329-8yFTIGIbGGduEZ6-7-jLx41nXj (org.eclipse.e4.rcp.feature.group 1.1.0.v20120521-2329-8yFTIGIbGGduEZ6-7-jLx41nXj)

        To: org.eclipse.core.runtime [3.8.0.v20120521-2346]

      Cannot satisfy dependency:

        From: Java EE IDE Feature 1.5.1.20120917-1257 (org.eclipse.epp.package.jee.feature.feature.group 1.5.1.20120917-1257)

        To: org.eclipse.platform.feature.group [4.2.1.v20120814-120134-9JF7BHVGFyMveli1uX6aTH0q-eAap6PAgOP5mO]

      Cannot satisfy dependency:

        From: Eclipse Platform 4.2.1.v20120814-120134-9JF7BHVGFyMveli1uX6aTH0q-eAap6PAgOP5mO (org.eclipse.platform.feature.group 4.2.1.v20120814-120134-9JF7BHVGFyMveli1uX6aTH0q-eAap6PAgOP5mO)

        To: org.eclipse.rcp.feature.group [4.2.1.v20120814-120134-7IAPA8BrHQicS-rjP0GbqK780kMy]

      Cannot satisfy dependency:

        From: Eclipse RCP 4.2.1.v20120814-120134-7IAPA8BrHQicS-rjP0GbqK780kMy (org.eclipse.rcp.feature.group 4.2.1.v20120814-120134-7IAPA8BrHQicS-rjP0GbqK780kMy)

        To: org.eclipse.e4.rcp.feature.group [1.1.0.v20120521-2329-8yFTIGIbGGduEZ6-7-jLx41nXj]

     

    Can anyone please help me out?

     

     

    Regards

    Abhishek