1 Reply Latest reply on Jun 13, 2017 12:01 AM by Ankit Gupta RSS
    bwarner-2 Newbie

    I am having trouble adding an animation (sequence) to my thingworx experience

    I started out by creating an animation (not a sequence) in Creo illustrate and trying to publish it to my thingworx experience.  I have created probably about 20 or more experiences so far, so I am somewhat familiar with creating and publishing experiences.  I created the file, published a .pvz, changed the file extension to .zip and extracted the .pvi file.  I then renamed the file extension to .pvz and created my experience.  When I created the experience, everything went as usual.  I added the thingmark, input the marker ID number (XXXX:XX) and added a couple of sliders and a button to play the sequence (in my case an animation).  I used the .pvz file when I needed a resource for my model, and I added the .pvi file under the "URL sequence" resource file prompt.  Everything seemed to be going well and looking just like it had in the videos I had watched on the thingworx website.  The experience also seemed to publish well, but when I went to use it, everything worked perfectly except the animation playing.  I did a bit of research and found that maybe I should have created a sequence instead of an animation.  I redid everything in the exact same way, except I created a sequence instead (including the renaming of the file, the extraction of the .pvi, etc.).  I still, however, had the same results.  I am not sure what I am doing wrong.  I did start creating my sequence/animation but bringing a .pvz file into illustrate (I saved my assembly file in creo parametric as a .pvz before bringing it in).  I am not sure if this is an issue or not, but it was never specified in any of the videos/tutorials that I watched/read what type of file to start with in illustrate, so I assumed it did not matter. Another couple of things that may be worth noting are that after I added the .pvi I navigated away from the model window to add the button and sliders, but when I came back, there was no text visible in the "URL sequence" window, as if it had never actually added.  Also, when I tried to bind the button to the playing of the animation, I dragged the button toggle value onto the model in the window on the left and there was not a "PLAY" option that was displayed.  There was, however, a "URL Sequence" option, and this is the one I chose.  In most of the videos and tutorials there was a "PLAY" option that was presented and this further leads me to believe that I am doing something wrong and the .pvi file was never actually attached properly.  I appreciate any and all help you can provide, and thank you in advance.