5 Replies Latest reply on Sep 5, 2017 6:29 AM by cmorfin RSS
    chrisqiu Newbie

    Does anyone know how to install ThingWatcher 8 via Docker?

    I use docke toolbox in win 2008 server r2, start a default machine with ip 192.168.99.101.

    I put the microservices.properties under E:\ThingWatcher, the content is:

    results.destination.uri=results://192.168.99.101:8080/results/models

    file.storage.path=/tmp

    dataset.webservices.url=

    dataset.app.id=

    dataset.app.key=

    and I run command

    docker run -d -p 8080:8080 --name result-standalone -v //E/ThingWatcher/db:/tmp/ -v //E/ThingWatcher/microservices.properties:/maven/results-standalone.properties twxml/result-standalone:2.0 -jar maven/result-standalone-2.0-bin.jar server /maven/results-h2-file.yml

    in the terminal, everything is OK, but when I try to access http://192.168.99.101:8080/results/models, it gives me nothing, but it is supposed to show something, right?

    then I run command

    docker run -d -p 8090:8080 --name training-standalone -v //E/ThingWatcher/microservices.properties:/maven/training-standalone.properties twxml/training-standalone:2.0.0

    in the terminal, it will give me message like:

    C:\Program Files\Docker Toolbox\docker.exe: Error response from daemon: oci runt

    ime error: container_linux.go:262: starting container process caused "process_li

    nux.go:339: container init caused \"rootfs_linux.go:57: mounting \\\"/E/ThingWat

    cher/microservices.properties\\\" to rootfs \\\"/mnt/sda1/var/lib/docker/aufs/mn

    t/9fe81874568f3c4761b309da30fefadfa19db5c958edacf34ceb49884cce7b09\\\" at \\\"/m

    nt/sda1/var/lib/docker/aufs/mnt/9fe81874568f3c4761b309da30fefadfa19db5c958edacf3

    4ceb49884cce7b09/maven/training-standalone.properties\\\" caused \\\"not a direc

    tory\\\"\""

    : Are you trying to mount a directory onto a file (or vice-versa)? Check if the

    specified host path exists and is the expected type.

    Does anyone know where went wrong? I just totally follow the official guide.