5 Replies Latest reply on Jul 21, 2017 11:48 AM by cmorfin RSS
    toml Explorer

    Failed to restart Thingworx analytics via docker

    I installed Thingworx Analytics 8.0 by Docker-Installation in win7 os. Everything is fina, and the analytics server was working. But  when I restarted my laptop, I can't start analytics server again. I used startup menu of windows program:Thingworx Analytics Server->thingworx analytics server start, the output is:

    Arg: option:  start

    Arg: label:  TAS

    Checking docker flavor ... exit status 1

    Running non-native docker

    Spinning up DockerMachinePTC...

    Starting "DockerMachinePTC"...

    (DockerMachinePTC) Check network to re-create if needed...

    (DockerMachinePTC) Waiting for an IP...

    Machine "DockerMachinePTC" was started.

    Waiting for SSH to be available...

    Detecting the provisioner...

    Started machines may have new IP addresses. You may need to re-run the `docker-machine env` command.

    Please note the ip for : DockerMachinePTC

    192.168.99.100

    03daa183b7ff

    Successfully started: 03daa183b7ff

    90f1b169c469

    Successfully started: 90f1b169c469

    0e8776fc3fa7

    Successfully started: 0e8776fc3fa7

    fff85151e2a2

    Successfully started: fff85151e2a2

    Successfully Started Docker Containers. Please wait ...

     

    My original url of TWA is 192.168.99.101:8080/analytics,  then I use 192.168.99.100:8080/analytics, my thingworx failed to verify configuration of twa,neither the original ip can connect.

     

    Anyone can help ?

     

    Thanks.

      • Re: Failed to restart Thingworx analytics via docker
        jgreiner Apprentice

        Hi Tom,

         

        1. Is there any error messages or system warnings displayed when you try to verify ThingWorx Analytics Connection?
        2. Are there any messages in the log files that are related to Analytics?

         

        Knowing this will make it easier to pin point what is causing the error.

         

        Thanks and Please Advise,

         

        John

          • Re: Failed to restart Thingworx analytics via docker
            toml Explorer

            Hi John,

             

            When verify configuration, I see an error message:Error invoking service: Invalid Analytics Server Version (ValidateMLServerVersion#5)

             

            In log file:

            2017-07-21 04:30:07.093+0800 [L: ERROR] [O: S.c.t.d.e.DSLScript] [I: ] [U: Administrator] [S: ] [T: http-nio-80-exec-1] GetVersion: ERROR retrieving version from instance 'VerifyMLInstance': JavaException: org.apache.http.conn.HttpHostConnectException: Connect to 192.168.99.100:8080 [/192.168.99.100] failed: Connection refused: connect

            2017-07-21 04:30:07.124+0800 [L: ERROR] [O: S.c.t.d.e.DSLProcessor] [I: ] [U: Administrator] [S: ] [T: http-nio-80-exec-11] Execution error in service script [TW_ML_Helper ValidateMLServerVersion] : Invalid Analytics Server Version (ValidateMLServerVersion#5)

             

            In my thingworx analytics server docker installiation folder, there is a folder of validation, tried to run docker_validator.exe,got the following message:

            Verifying docker installation ...

            Command output:  Docker version 17.05.0-ce, build 89658be

            docker installation verified

            Error accessing docker daemon:  exit status 1

             

             

            Hope these is useful for your diagnostic.

             

            Thanks

            Tom

              • Re: Failed to restart Thingworx analytics via docker
                cmorfin Communicator

                Hi Tom

                 

                It woudl be useful if you could provide the output of:

                - docker ps -a

                - docker logs analytics > analytics.log  , and attach the analytics.log file created.

                - docker-machine ls

                 

                Thanks

                Christophe

                  • Re: Failed to restart Thingworx analytics via docker
                    toml Explorer

                    Hi Christophe,


                    I installed docker toolbox in Win7. And I uninstall thingworx analytics server and  removed two machines of docker: default and DockerMachinePTC, then I reinstall thingworx analytics server. The twa server is working. Open Docker Quickstart Terminal and run command:

                    docker ps -a

                    There is no analytics container listed.


                    Run docker ps -a under folder of C:\Program Files\Docker Toolbox>

                    I got:

                    docker ps -a

                    error during connect: Get http://%2F%2F.%2Fpipe%2Fdocker_engine/v1.29/containers/json?all=1: open //./pipe/docker_engine: The system cannot find the file specified. In the default daemon configuration on Windows, the docker client must be run elevated to connect. This error may also indicate that the docker daemon is not running.


                    And run docker-machine ls I got:

                    docker-machine ls

                    NAME               ACTIVE   DRIVER       STATE     URL                         SWARM   DOCKER        ERRORS

                    default            -        virtualbox   Running   tcp://192.168.99.101:2376           v17.06.0-ce

                    DockerMachinePTC   -        virtualbox   Stopped      


                    When run thingworx analytics server start, it said DockerMachinePTC   is already running, but docker-machine ls tells me it's stopped. I am confused.


                    It sounds like when I restart my laptop, I can't run twa server after I run Docker Quickstart Terminal, so this is about IP? I am not familiar with docker.



                    Thanks & Best Regards

                    Tom

                      • Re: Failed to restart Thingworx analytics via docker
                        cmorfin Communicator

                        Hi Tom

                         

                        On Docker Toolbox, if you execute docker ps -a, by default it lists the containers defined in the default docker machine. So it is normal that you would not see the analytics container because it is running inside the DockerMachinePTC.

                        To switch docker machine, execute

                        eval "$(docker-machine env DockerMachinePTC)"

                        then docker ps -a will list the container defined in this docker machine.

                         

                        However the eval command will only work if the DockerMachinePTC runs.

                        From what you wrote the status seems unclear.

                        You could open Virtual box manager and check if the DockerMachinePTC appears as running there or not.

                        If it is not running , then it seems the output of docker-machine ls would be correct and you could start it with docker-machine start DockerMachinePTC


                        Hope this help

                        Kind regards

                        Christophe