8 Replies Latest reply on Aug 31, 2017 11:14 PM by lzhou RSS
    kchouhan Newbie

    error accessing Thingworx analytics server

    Hello,

     

    We installed Thingworx analytics server on a machine with windows 7 OS.We used docker toolbox version 17.03.0.ce . The server installation is successful,there are no errors in the thingWorxAnalyticsServer-install.log . From the installation summary,got the analytics server url as-

    But when I try to access it from browser to verify the installation using  - http://192.168.99.102:8080/analytics/1.0/about/versioninfo .I get something like-

    I have doubt regarding the tomcat external port - 8080 which is asked in confuguration while installation.What does this refer to ?Do we need to install tomcat on the machine ?Where is it pointing to ?

    Please help

    Regards

    Kirti

      • Re: error accessing Thingworx analytics server
        carko Creator

        Hello, Kirti Chouhan.

         

        I'll locate a resource in the ThingWorx Analytics group to help you out with this.

         

         

        -- Craig A.

        • Re: error accessing Thingworx analytics server
          jgreiner Apprentice

          Hi Kirti,

           

          The Port number 8080 and Tomcat are all located on the Docker Machine that is created during the Installation Process and since that was successful, it should all be good.

           

          Sometimes issues like this have happened due to either network issues or firewall issues.

           

          To see if it is a network issue, are you able to ping the server?

           

          If you are able to ping the server can you check out this article on how to test if the firewall is causing the issue.

           

          Let me know how everything goes or if you have any further questions or concerns.

           

          Warm Regards,

           

          John

            • Re: error accessing Thingworx analytics server
              lzhou Apprentice

              I have the same issue.

              And I am very sure that I have stopped windows firewall already.

              I can ping the ip, and I also can telnet ip 8080, and it is OK too.QQ截图20170823110905.png

               

              And I can visit my thingworx in the same PC using port 80.

              • Re: error accessing Thingworx analytics server
                kchouhan Newbie

                Hi John,

                 

                Thanks for your support.

                This issue got resolved when I restarted Analytics server and I was able to access the Analytics server API Guide.I am able to ping the server from my machine.But now the problem is I am not able to access it from other machines which are in the same network.We have Thingworx installed on another machine which is a cloud server so I am not able to connect analytics server from analytics builder on that machine.Can you guide me on this.

                 

                Also I have found some network settings for docker machine PTC .What does this mean?

                 

                Thanks & Regards,

                Kirti

                  • Re: error accessing Thingworx analytics server
                    jgreiner Apprentice

                    Hi Kirti,


                    I see you marked my answer as correct.  Were you able to get everything running correctly?


                    As for your question on Port Forwarding, That is a feature of VirtualBox which I am not an expert on, but I found some useful information on the topic in the Virtual Box manual which you can access here.


                    Let me know if you have any further questions or concerns.


                    Warm Regards,


                    John

                      • Re: error accessing Thingworx analytics server
                        rvuta Explorer

                        Hi John Greiner,

                        We are facing same issue of "This site can not be reached".

                        initially it is working fine, but  because of some reasons we uninstalled and did re installation again.

                        after re installation we are getting this error.

                         

                        we didn't receive any errors while installing.

                        As we were able to access it initially,hope our firewall was disabled.

                         

                        what else we have to check to resolve this issue.

                         

                        Please help.

                         

                        Regards,

                        Raji.