0 Replies Latest reply on Aug 28, 2017 10:12 AM by festes RSS
    festes Newbie

    Cannot connect to Thingworx Composer

    The following message is being displayed when I try to open Thingworx Composer:

    Error connecting to the ThingWorx server.

    When I try to 'Publish' apps through Thingworx Studio, I get the following error message:

    Internal Server Error

     

    The log shows this:

     

    [08/28/2017 08:45:32]  [0mGET /%7B%7B::projectType.imgPath%7D%7D  [32m200  [0m20.991 ms - 2201 [0m

    [08/28/2017 08:45:32]  [0mGET /%7B%7B::view.imgPath%7D%7D  [32m200  [0m4.629 ms - 2201 [0m

    [08/28/2017 08:45:32]  [0mGET /%7B%7BviewType.imgPath%7D%7D  [32m200  [0m1.765 ms - 2201 [0m

    [08/28/2017 08:45:32]  [0mGET /images/%7B%7B::w.name%7D%7D.png  [32m200  [0m1.144 ms - 2201 [0m

    [08/28/2017 08:45:34] error: [twx-studio:proxy] Proxy error { Error: getaddrinfo ENOTFOUND dz4khvj2.pp.vuforia.io dz4khvj2.pp.vuforia.io:443

    [08/28/2017 08:45:34]     at errnoException (dns.js:28:10)

    [08/28/2017 08:45:34]     at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:76:26)

    [08/28/2017 08:45:34]   code: 'ENOTFOUND',

    [08/28/2017 08:45:34]   errno: 'ENOTFOUND',

    [08/28/2017 08:45:34]   syscall: 'getaddrinfo',

    [08/28/2017 08:45:34]   hostname: 'dz4khvj2.pp.vuforia.io',

    [08/28/2017 08:45:34]   host: 'dz4khvj2.pp.vuforia.io',

    [08/28/2017 08:45:34]   port: 443 } null 200

    [08/28/2017 08:45:34] error: [twx-studio:proxy] twx server proxy error...

    [08/28/2017 08:45:34] error: [twx-studio:proxy]  Error: getaddrinfo ENOTFOUND dz4khvj2.pp.vuforia.io dz4khvj2.pp.vuforia.io:443

    [08/28/2017 08:45:34]     at errnoException (dns.js:28:10)

    [08/28/2017 08:45:34]     at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:76:26)

    [08/28/2017 08:45:34]  [0mGET /thingworx/Composer  [31m500  [0m117.093 ms - - [0m

     

    Can anyone please help me fix this?