2 Replies Latest reply on Oct 19, 2017 11:53 AM by jhorsley RSS
    jhorsley Newbie

    Error KEPServerEX\Runtime  Attempt to add item **** Failed.

    Does anyone know how to troubleshoot this? The items that are attempting to add have been verified as connected with Ethernet cables. The Kepware license was installed correctly, and runtime is started.  There is blank section where the ProgID is in the KEPServerEX settings.  Should there be something here? I have seen other references to OPC.Server.V1 in the help.  Can anyone direct to a source for the proper settings here?

    Here is a clip of the logs with many more items attempted but not shown.  This log just repeats:

     

    9/25/2017   17:44:00     Information  KEPServerEX\Runtime  Runtime performing exit processing.

    9/25/2017   17:46:17     Information  KEPServerEX\Runtime  Kepware Communications Server 5.18

    9/25/2017   17:46:23     Information  KEPServerEX\Runtime  Simulator device driver loaded successfully.

    9/25/2017   17:46:23     Information  KEPServerEX\Runtime  Runtime service started.

    9/25/2017   17:46:23     Information  KEPServerEX\Runtime  Starting Simulator device driver.

    9/25/2017   17:46:23     Information  Simulator            Simulator Device Driver V5.18.673.0

    9/25/2017   17:46:23     Information  KEPServerEX\Runtime  Advanced Tags Plug-in V5.18.673.0

    9/25/2017   17:46:23     Information  KEPServerEX\Runtime  Data Logger Plug-in V5.18.673.0

    9/25/2017   17:46:23     Information  KEPServerEX\Runtime  Oracle Connector Plug-in V5.18.673.0

    9/25/2017   17:46:23     Information  KEPServerEX\Runtime  Alarms & Events Plug-in V5.18.673.0

    9/25/2017   17:46:23     Information  KEPServerEX\Runtime  SNMP Agent Plug-in V5.18.673.0

    9/25/2017   17:46:23     Information  KEPServerEX\Runtime  Media Level Redundancy Plug-in V5.18.673.0

    9/25/2017   17:46:23     Information  KEPServerEX\Runtime  EFM Exporter V5.18.673.0

    9/25/2017   17:46:23     Information  KEPServerEX\Runtime  Connection Sharing Plug-in V5.18.673.0

    9/25/2017   17:46:23     Information  KEPServerEX\Runtime  Security Policies Plug-in V5.18.673.0

    9/25/2017   17:46:23     Information  KEPServerEX\Runtime  Local Historian Plug-in V5.18.673.0

    9/25/2017   17:46:23     Information  KEPServerEX\Runtime  IDF for Splunk V5.18.673.0

    9/25/2017   17:46:23     Information  KEPServerEX\Runtime  Scheduler Plug-in V5.18.673.0

    9/25/2017   17:50:30     Error        KEPServerEX\Runtime  Attempt to add item 'ChannelUV.DeviceUV.BOX2_PWC_LEAK2_ALARM' failed.

    9/25/2017   17:50:30     Error        KEPServerEX\Runtime  Attempt to add item 'ChannelUV.DeviceUV.BOX2_EOCR_TRIP1_ALARM' failed.

    9/25/2017   17:50:30     Error        KEPServerEX\Runtime  Attempt to add item 'ChannelUV.DeviceUV.BOX1_O2_HIGH_ALARM' failed.

    9/25/2017   17:50:30     Error        KEPServerEX\Runtime  Attempt to add item 'ChannelUV.DeviceUV.BOX3_HEATERA_HIGH_ALARM' failed.

    9/25/2017   17:50:30     Error        KEPServerEX\Runtime  Attempt to add item 'ChannelUV.DeviceUV.BOX1_TEMPERATURE' failed.

    9/25/2017   17:50:30     Error        KEPServerEX\Runtime  Attempt to add item 'ChannelUV.DeviceUV.BOX3_EOCR_TRIP2_ALARM' failed.

    9/25/2017   17:50:30     Error        KEPServerEX\Runtime  Attempt to add item 'ChannelUV.DeviceUV.BOX3_H2O_HIGH_ALARM' failed.

    9/25/2017   17:50:30     Error        KEPServerEX\Runtime  Attempt to add item 'ChannelUV.DeviceUV.BOX3_OXYGEN_DENSITY' failed.

    9/25/2017   17:50:30     Error        KEPServerEX\Runtime  Attempt to add item 'ChannelUV.DeviceUV.BOX3_SSR2_BIMETALTRIP60_ALARM' failed.

    9/25/2017   17:50:30     Error        KEPServerEX\Runtime  Attempt to add item 'ChannelUV.DeviceUV.BOX3_EOCR_TRIP3_ALARM' failed.

    9/25/2017   17:50:30     Error        KEPServerEX\Runtime  Attempt to add item 'ChannelUV.DeviceUV.BOX3_PRESSURE' failed.

    ....... and so on.

      • Re: Error KEPServerEX\Runtime  Attempt to add item **** Failed.
        stmarchessault Creator

        Greetings Jeremyn,

         

        This Event Log message in KEPServerEX usually occurs when a Client application (which would include any third-party client application, the OPC Quick Client, or an internal client like the Datalogger Plug-in or Advanced Tags Plug-in), has attempted to add an item to a poll subscription, but that item does not exist in the KEPServerEX namespace.

         

        Most often, this occurs when the Client application has been configured to read the tags in a KEPServerEX project, then the server project has been changed, and the Client project now includes references that no longer exist.

         

        With this in mind, there are a couple of things to verify:

        1. Looking at one example of this error message: "ChannelUV.DeviceUV.BOX1_TEMPERATURE". Does the Channel "ChannelUV", with the Device "DeviceUV" exist in the project?

        2. What Client applications are connected with KEPServerEX? Can you view the tags configured in those applications?

        3. I am not sure which ProgID setting you are referring to, please explain this further if you are unable to solve this with the information above.

         

         

        Best regards,

        Steven M