11 Replies Latest reply on Oct 17, 2017 8:21 AM by nagrawal-2 RSS
    nagrawal-2 Explorer

    License Invalid

    Hi,

     

    I have installed the 120 days trial version of Thingworx locally on Linux system few weeks back.  A few days back I was making some port configuration with Tomcat on our server which in turn caused Thingworx to stop working. After checking Application log, I came to know that somehow the License file got invalid.

     

    I tried to install everything from scratch again but this time, unfortunately, I couldn't find 8.0 version here: https://developer.thingworx.com/resources/downloads, so I have installed 8.1 version without knowing the new procedure of Licensing but ended up to same invalid license issue. Then I found this article here:Article Viewer | PTC .

    There is a licenseRequestFile.txt in /ThingworxPlatform folder where I found my Device Id but not activation id. When I tried to go to PTC account to generate license, I couldn't find any way to generate one fro Trial version. https://support.ptc.com/apps/licensePortal/auth/ssl/index

     

    I am not sure how would I resolve this issue, I am in middle of developing my PoC

     

    Best regards,

    Neetu