5 Replies Latest reply on Nov 1, 2017 1:56 PM by stmarchessault RSS
    mkervan Newbie

    cannot connect to Thingworx from Kepserverex V6 Thingworx native interface

    1.png

      • Re: cannot connect to Thingworx from Kepserverex V6 Thingworx native interface
        slangley Explorer

        Hi Metin.

         

        Please check that the Thing name (Demo_umutcolak) exists in ThingWorx Composer.  If so, open it and copy the application key to the Application Key property for Thingworx in the KEPServerEX properties.

         

        I also see that you have legacy mode enabled.  Are you running KEPServerEX 6.2?  If not, you will need to upgrade in order to run Manufacturing Apps.

         

        Please let me know if this information was helpful.  If not, we will dig deeper into the issue.

         

        Regards.

         

        --Sharon

          • Re: cannot connect to Thingworx from Kepserverex V6 Thingworx native interface
            mkervan Newbie

            Hello Sharon,

            Thank you for your reply. Yes, it exists in the composer and I am running KepServerEX 6.2. I've solved the host name problem but now I have another problem: "error: could not initialize a secure socket connection" 

            Do you have an idea about the cause of this problem?

             

             

            Thank you

              • Re: cannot connect to Thingworx from Kepserverex V6 Thingworx native interface
                stmarchessault Creator

                Greetings Metin,


                Here is an excerpt from the KEPServerEX v6.2 Server Help manual, in the Event Log error message section:

                 

                "'Connection to ThingWorx failed. | Platform <host:port resource>, error: <reason>.'

                Possible Cause: The connection to the ThingWorx platform could not be established.

                Possible Solution:

                1. Verify that the host, port, resource, and application key are all valid and correct.

                2. Verify that the host machine can reach the composer on the ThingWorx platform.

                3. Verify that the proper certificate settings are enabled if using a self-signed certificate or no encryption."

                 

                If any of the above parameters are incorrect, a socket connection cannot be formed between KEPServerEX and ThingWorx. Extracting from the help description, here is a checklist to go through for these items:

                 

                1. a. Host: This is the URL used to connect with your ThingWorx instance. This will be tested in Step 2 below.

                1. b. Port: This is configured in the server.xml configuration file for Tomcat. The default, non-encrypted port is 80.

                1. c. Resource: You will need to have a Resource value entered here. Try the default "/Thingworx/WS".

                1. d. Application Key: Follow Sharon's instructions to verify you have copy/pasted the Application Key directly from Composer

                 

                2. Now, on the same PC where KEPServerEX is installed, open a web browser and attempt to connect to ThingWorx Composer at this address:

                <Host>:<Port>/Thingworx

                 

                3. Unless you are using SSL or self-signed certificates, the best options for the three certificate/encryption options are:

                Trust self-signed certificates: No

                Trust all certificates: No

                Disable encryption: Yes

                 

                Please let us know how it goes after going through these settings and suggestions.

                 

                 

                Best regards,

                Steven M

            • Re: cannot connect to Thingworx from Kepserverex V6 Thingworx native interface
              stmarchessault Creator

              Greetings Metin Kervan

               

              Following up with you on the original question posted here, can you please indicate if the recommendations given by me on 18 Oct answered this for you?

               

              If this adequately answered your question, please mark the reply as the "Correct Answer."

               

              Or, if you are still unresolved on your original question, let us know and we can continue troubleshooting this with you. This feedback is a key step toward ensuring Community users with a similar issue are able to locate the information they need.

               

               

              Best regards,

              Steven M