6 Replies Latest reply on Dec 13, 2017 1:09 PM by bozkan RSS
    bozkan Newbie

    Thingworx Analytics Extension - Import Error

    Hello everyone,

     

    When I try to import ThingWorx-Analytics-8.1.0, I got two error;

     

    1. Unable to process import: Unable to update mediaEntity: ModelTagVocabulary [TW] Already Exists
    2. Unable to delete ThingWorx_Analytics_Console_Extension:8.1.0.  This is likely due to other errors: ExtensionPackage ThingWorx_Analytics_Console_Extension Does Not Exist

     

    I checked the entity which name is Applications. Also, Model Tags->Applications->Manage Terms is empty. I don't know what is the reason. Could somebody help me?

     

    Regards,

      • Re: Thingworx Analytics Extension - Import Error
        cmorfin Communicator

        Hi Ozkan

         

        Could you please attach your ApplicationLog.log file ?

        Also could you confirm:

        - what is yoru persistence provider- is it a fresh installation of ThignWorx 8.1 or an upgraded one ?

        - did you have a previous extension of ThingWorx analytics already installed

        - did you attempt several time to install the extension

        - what is the OS on which you run ?

         

        Thank you

        Kind rgeards

        Christophe

          • Re: Thingworx Analytics Extension - Import Error
            bozkan Newbie

            Hi Christophe,

             

            Firstly, thanks for your reply.

             

            I attached log file, also you can find my answers below. Thanks again.

             

            - what is yoru persistence provider- is it a fresh installation of ThignWorx 8.1 or an upgraded one ?

            - Not upgrade, I installed new on new vm.

            - did you have a previous extension of ThingWorx analytics already installed

            - Nope, I never try to install previous version of extension. I deployed new tw instance after that I tried to import analytic extension.

            - did you attempt several time to install the extension

            - Yes,

            - what is the OS on which you run ?

            - Windows Server 2016

              • Re: Thingworx Analytics Extension - Import Error
                cmorfin Communicator

                Hi Ozkan

                 

                In Composer could you access Model Tags (under MODELLING), do you see a TW model tag here ?

                Could you also post the extensions listed under Import/Export > manage ?

                 

                Thank you

                kind regards

                Chrisotphe

                  • Re: Thingworx Analytics Extension - Import Error
                    bozkan Newbie

                    Hi Chrisotphe,

                     

                    Model Tags has just Application entity. Extension list is empty. I checked it from menu (Import/Export > Manage)

                     

                    Regards,

                      • Re: Thingworx Analytics Extension - Import Error
                        cmorfin Communicator

                        Hi Ozkan

                         

                        I think I have isolated the root cause. I was able to reproduce the same behaviour as you had.

                        It appears that the root error is not " Unable to update mediaEntity: ModelTagVocabulary [TW] Already Exists" . This is an error you got after a subsequent import attempt.

                        Upon first import the error was "Unable to process import: License is not available for Product: THINGWORX_FOUNDATION Feature: twx_named_user"

                         

                        You indeed do need to have a twx_named_user feature in order to import the ThingWorx Analytics Extension.

                        You would therefore need to check on the Licensing tool the activation ids that you have got for the Product ThingWorx - User and add it to your device.

                        Then you should be able to import the extension.

                         

                        As mentionned above I did indeed got the same situation without twx_named_user, but was able to import after adding it.

                         

                         

                        Kind regards

                        Christophe