3 Replies Latest reply on Jan 5, 2018 9:10 AM by supandey RSS
    vkoneri Newbie

    Thingworx composer frozen at launch screen

    Unable to open thingworx composer on web browser. It freezes at launch screen.

     

    Following are the steps taken:

     

    1. Clear cache and cookies.

    2. Tried on multiple browsers

    3. Restart thingworx done

     

    Still no luck. Attaching screen shot.

     

      • Re: Thingworx composer frozen at launch screen
        supandey Ninja

        Hi Venkatesh, is this a local installation or hosted? Is this 8.1 or 8.0 version of ThingWorx?  Are you seeing any licensing issues in the Tomcat's catalina log or may be in ThingWorx's own logs? May be you can share them here so it can be reviewed.

          • Re: Thingworx composer frozen at launch screen
            vkoneri Newbie

            It is hosted on AWS cloud. Thingworx 8.0

             

            No logs found in the thingworx logs. No logs specific to license found in tomcat logs either

             

            Error logs that i could find

             

            05-Jan-2018 00:32:24.904 INFO [https-jsse-nio-443-exec-8] org.apache.tomcat.websocket.server.WsRemoteEndpointImplServer.doClose Failed to close the ServletOutputStream connection cleanly

            java.io.IOException: Broken pipe

                    at sun.nio.ch.FileDispatcherImpl.write0(Native Method)

                    at sun.nio.ch.SocketDispatcher.write(SocketDispatcher.java:47)

                    at sun.nio.ch.IOUtil.writeFromNativeBuffer(IOUtil.java:93)

                    at sun.nio.ch.IOUtil.write(IOUtil.java:65)

                    at sun.nio.ch.SocketChannelImpl.write(SocketChannelImpl.java:471)

                    at org.apache.tomcat.util.net.SecureNioChannel.flush(SecureNioChannel.java:143)

                    at org.apache.tomcat.util.net.SecureNioChannel.close(SecureNioChannel.java:494)

                    at org.apache.tomcat.util.net.NioEndpoint$NioSocketWrapper.close(NioEndpoint.java:1201)

                    at org.apache.tomcat.websocket.server.WsRemoteEndpointImplServer.doClose(WsRemoteEndpointImplServer.java:167)

                    at org.apache.tomcat.websocket.WsRemoteEndpointImplBase.close(WsRemoteEndpointImplBase.java:710)

                    at org.apache.tomcat.websocket.WsSession.sendCloseMessage(WsSession.java:599)

                    at org.apache.tomcat.websocket.WsSession.onClose(WsSession.java:512)

                    at org.apache.tomcat.websocket.server.WsHttpUpgradeHandler.close(WsHttpUpgradeHandler.java:233)

                    at org.apache.tomcat.websocket.server.WsHttpUpgradeHandler.upgradeDispatch(WsHttpUpgradeHandler.java:155)

                    at org.apache.coyote.http11.upgrade.UpgradeProcessorInternal.dispatch(UpgradeProcessorInternal.java:54)

                    at org.apache.coyote.AbstractProcessorLight.process(AbstractProcessorLight.java:53)

                    at org.apache.coyote.AbstractProtocol$ConnectionHandler.process(AbstractProtocol.java:861)

                    at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1455)

                    at org.apache.tomcat.util.net.SocketProcessorBase.run(SocketProcessorBase.java:49)

                    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)

                    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)

                    at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)

                    at java.lang.Thread.run(Thread.java:745)

              • Re: Thingworx composer frozen at launch screen
                supandey Ninja

                When you say no logs found for ThingWorx platform, are you referring that there are no logs at all in \ThingworxStorage\logs folder or are you not finding the location where ThingworxStorage exists?

                 

                Is this a first time deployment ? If not, did it ever work? If it did work previously, what was changed? The error shared above seems to be coming from tomcat log, I expect that the ThingWorx logs must be getting populated since you can reach the stage where at least the splash screen for ThingWorx is shown meaning many of the ThingWorx subsystems did manage to start up.

                 

                Final question what sort of Persistence provider are you using with your ThingWorx?