3 Replies Latest reply on Jan 9, 2018 3:47 AM by supandey RSS
    abarletta Newbie

    Unable to select Blog Widget in Workspace and visually missing in design space

    I've ran into what seems a rather strange bug. I included a Blog Widget in a Mashup. After testing out which "view" I liked best (Expanded, List, or Log), the Widget is visually missing from the design space and I cannot select it in the list of Widgets under the Workspace tab. When I say I cannot select it, I mean the widget "blog-196" is highlighted, but it does not highlight anything in the design space and the Properties table just below does not populate the Blog Widget's information. I'd love to delete it and just re-insert another Blog Widget, but you have to be able to select it first. It is a rather annoying bug. I also already restarted my tomcat. All this said, when accessing the Mashup outside of the Composer, the Blog Widget is exactly where I left it. Has anyone run into anything like this before? Am I missing something obvious here? (Unfortunately, I didn't even get the chance to bind it to any services or anything, so I cannot select it in the Connections pane either.) Running ThingWorx 8.1.1-b108

      • Re: Unable to select Blog Widget in Workspace and visually missing in design space
        supandey Ninja

        Hi Aldo, I'm aware of currently Google Widget preview is not visible when editing the Mashup in New Composer on the same version of ThingWorx on which you are reporting that bug. Is it possible for you to share a screenshot of what you are seeing and if its only happening in New Composer? Have you tried opening the Mashup in Classic composer / old composer?

          • Re: Unable to select Blog Widget in Workspace and visually missing in design space
            abarletta Newbie

            Hey Sushant, Unfortunately have only been using it in the old composer; I hadn't even thought of trying on the New Composer, but it turns out it doesn't show up there either.

            Below is where the blog should be, and where it does appear in the runtime and preview.

             

            Below are both images of the New and Old composer. Blog-196 is selected, but it is stuck on what ever was previously selected (in this case, the Mashup) and it is simply invisible and will not allow itself to be selected.

              • Re: Unable to select Blog Widget in Workspace and visually missing in design space
                supandey Ninja

                Thanks Aldo for detail input, I could not reproduce this on ThingWorx 8.1.0 , will give it a try on 8.1.1. Just so I'm not missing something specific to your mashup, is it possible for you to export this mashup and share with me? You can remove all the entities from the mashup you don't wish to share externally, alternatively you can PM me the attachment.

                 

                Additionally, I wanted to check if you use the web browser debugger while viewing the mashup in runtime, do you see any error? Are you able to select the part of the screen where the blog is supposed to show up? Although like you mentioned currently there's no binding to the blog so likely nothing will show up during runtime. Is this the only mashup where you are running into this issue with Blog or you have other mashups with similar sort of behaviour from Blog widget?